After Release Login could be affected: Beck Tenant (c1da7c2-2ffd-4ebb-b774-05620469e36e)

Incident Report for Noxtua

Resolved

This incident has been resolved.
Posted May 27, 2026 - 19:18 CEST

Monitoring

A fix has been applied. The issue only affected the UX of the web-site, that made it impossible to upload documents.
Posted May 27, 2026 - 18:55 CEST

Investigating

We are currently investigating this issue.
Posted May 27, 2026 - 18:38 CEST
This incident affected: Application (app.noxtua.com).