Web App is sometimes a blank page (All tenants)

Incident Report for Noxtua

Resolved

The issue was resolved at 11:55
Posted May 28, 2026 - 11:55 CEST

Identified

We have found the issue and working on a fix.
Posted May 28, 2026 - 11:30 CEST
This incident affected: Application (app.noxtua.com).